1994 Stock Radio

Discussion in 'New Owner Questions' started by trimjc, Jan 2, 2009.

  1. trimjc

    trimjc Enthusiast

    Posts:
    5
    Joined:
    Dec 31, 2008
    Anyone experianced this problem with their stock stereo?

    Stero turns on - no sound from speakers

    Checked the stero and amp fuses...no luck

    Jerry
     
  2. Bandit3

    Bandit3 Viper Owner

    Age:
    70
    Posts:
    1,510
    Joined:
    Sep 26, 2001
    Location:
    Atlanta
    Time for an upgrade.
     
  3. Mad Max 93 RT10

    Mad Max 93 RT10 Enthusiast

    Posts:
    186
    Joined:
    Dec 29, 2008
    Location:
    Wallingford, CT
    you have two seperate amps that run your speakers. one on each side of your trunk. if you have no sound at all its most likely your radio. the stock head units are a really cheap alpines and should be replaced anyways. I can get you any radio you like and ship it to you. Or if your close to CT you can just come to my shop and I can do it. www.MTSCT.com JD.
     
  4. CitySnake

    CitySnake Enthusiast

    Posts:
    7,116
    Joined:
    Sep 18, 2001
    Location:
    Manhattan, USA
    I've got a GEN 2 OE radio for sale if you're interested.
     
  5. sdaddy

    sdaddy Viper Owner

    Posts:
    421
    Joined:
    Dec 22, 2006
    Location:
    Jacksonville, FL
    Radio in my 94 used to change from FM to AM when I hit a bump, or if on CD jumped to the number 2 CD when I hit a bump. I left it alone and it eventually quit doing that. These cars are a life form of their own and sometimes demonstrate powers of self healing.
     

Share This Page