CEL/MIL - Check Engine Light Question & Codes

Discussion in 'SRT10 and SRT10 Coupe Discussions' started by Guy, Apr 29, 2012.

  1. Guy

    Guy Viper Owner

    Posts:
    158
    Joined:
    Mar 27, 2008
    Location:
    Europe
    I've been having trouble with an O2 sensor that never really threw a "check engine light", except one time on a short drive. It has since been replaced, but I was reading up about the CEL/MIL function and have a question (or two)..

    When you turn the key on your Gen-3 all the way on, it it normal for the CEL to stay on? When I performed the "on-off on-off on-off on" trick, it blinked 11 times. To the best of my searching generic OBD-2 codes, that means "no fault".. Is this normal? The CEL is off when the car is started and running.

    Does the Gen-3 display in the odometer area a Pxxxx code when one exists? I have a Craftsman OBD-2 scanner and used that the time the CEL came on, forgot to try the on-off trick..

    Thanks!

    Guy
     
  2. BLK04

    BLK04 Viper Owner

    Posts:
    78
    Joined:
    Dec 21, 2011
    Location:
    New Brunswick ,Canada
    cycle the key to the on position 3 times & the odometer will give you the trouble codes , if none there it will read "done" when you leave the key on without the engine running the light will stay on because of no oil pressure ...
     
  3. Guy

    Guy Viper Owner

    Posts:
    158
    Joined:
    Mar 27, 2008
    Location:
    Europe
    Awesome will try again, thanks!
     

Share This Page