Post quetioning effectiveness of sponsoring vendor's part deleted

Discussion in 'Posting Policies' started by PhoenixGTS, Jul 31, 2007.

  1. PhoenixGTS

    PhoenixGTS Viper Owner

    Posts:
    2,681
    Joined:
    Jul 9, 2004
    Location:
    Phoenix Arizona
    I made a post to a thread regarding my first hand knowledge gained from installing and testing a part manufactured by one of the sponsoring vendors. Not mean. Not an attack Just a note that although it was a nice part it did nothing on my car. Now my post has disappeared. This kind of censorship is sad for anyone who might actually use the search function and try to learn about actual users' experience with an available part.
     
  2. dave6666

    dave6666 Enthusiast

    Posts:
    14,975
    Joined:
    Jul 18, 2007
    Location:
    Explaining Viper things to you
    Big Viper strikes...
     
  3. agentf1

    agentf1 Viper Owner

    Age:
    58
    Posts:
    2,606
    Joined:
    Dec 27, 2001
    Location:
    Phila Suburbs
    Welcome to the internet. I do not know what or if anything happened here but can say that I see this happen on just about every forum that has supporting vendors. I can't see why this place would be any different.
     
  4. Lake Murray Viper

    Lake Murray Viper Viper Owner

    Posts:
    149
    Joined:
    Aug 14, 2006
    Location:
    Chapin, SC
    For some reason many sites do not feel that free speech is a good thing. :dunno:
     
  5. SylvanSRT

    SylvanSRT Enthusiast

    Posts:
    3,677
    Joined:
    Feb 2, 2003
    Location:
    Sylvan Lake, MI, USA
    repost info here please?
     
  6. ViperTony

    ViperTony Enthusiast

    Posts:
    7,555
    Joined:
    Apr 3, 2006
  7. C O D Y

    C O D Y Enthusiast

    Posts:
    2,432
    Joined:
    Aug 21, 2000
    Location:
    Vancouver, WA
    Cleart out some of your PMs. You can not receive any more.
     
  8. PhoenixGTS

    PhoenixGTS Viper Owner

    Posts:
    2,681
    Joined:
    Jul 9, 2004
    Location:
    Phoenix Arizona
  9. PhoenixGTS

    PhoenixGTS Viper Owner

    Posts:
    2,681
    Joined:
    Jul 9, 2004
    Location:
    Phoenix Arizona
    I am trying and cannot figure out what is going on with my PM account. I think I will look to see if there is anything to save and wipe the PMs clean. Sorry for the kick-backs. I am getting e-mails notices of the incoming failures though, so that system is working fine. It ain't easy being an outlaw!
     

Share This Page