1995 RT/10 Headlight Problem

Discussion in 'RT/10 and GTS Discussions' started by Patrick Boyle, Jun 13, 2019 at 1:22 PM.

  1. Patrick Boyle

    Patrick Boyle Enthusiast

    Posts:
    1
    Joined:
    Jan 4, 2019
    Location:
    Massachusetts
    I don't usually take my car out at night, so just discovered this problem a few nights ago. When i pull out the headlight switch nothing happens. The foglights switch does not do anything either, but I'm guessing that is because they only work with the headlights on.

    Oddly enough the brights do come on when i pull on the stalk. Has this happened to anyone else? Where should I start looking for the problem? Im thinking it could be a fuse, or a problem with the switch, but thought someone might be able to give me some guidance.

    Thanks,

    Patrick
     
  2. Steve-Indy

    Steve-Indy VCA Venom Member - Great Lakes

    Posts:
    8,035
    Joined:
    Oct 2, 2000
    Location:
    Zionsville,IN. USA
    First, check your fuses.

    After that, take a look at the actual headlight switch...which have been known to fail.
     
    Bonkers likes this.
  3. ViperRed

    ViperRed Viper Owner

    Posts:
    153
    Joined:
    Oct 4, 2006
    Location:
    Bahrain
    My car is a 93, and on the 1st pull of the switch, only the side lights and tail lights come on.
    Also, in this position, the fog lights do not come on when I press the fog light switch. I have noticed this too.

    On the 2nd pull of the switch, the headlights come on. In this mode, I am able to switch on the fog lights too.

    By pulling back on the stalk, full beams flash.

    What's the issue you're having?

    When you say "brights", are you referring to the main lights? Or in Europe, they call them "dip beams"
     

Share This Page