1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Mini Subs vs Mid Bass

Discussion in 'RT/10 and GTS Discussions' started by fed007, May 9, 2013.

  1. fed007

    fed007 Enthusiast

    Posts:
    40
    Joined:
    Apr 8, 2009
    Hi , my stereo sounds like garbage, so I am changing it.

    I have been trying to figure out whether the Viper (mine 1995 RT/10) really has stock subs or if they are wannabe subs and are actually mid bass.

    I changed the right door speakers last night to a two way setup using the JL Audio C2s / w tweeters. Door Speakers... these sound pretty good.

    The part I need help with is pulling the trigger on the speakers in the middle console. I am leaning towards these JL Audio Mini Subs

    The door speakers are nice and punchy now and very crisp on the hi end and probably has to do with to the amp I added ( JL Audio XD500 ) but what should the center models be?

    The amp has inputs for the sub so I plug the subs in... it is obvious that the factory subs are not capable of any kind of sufficient low frequency, a small turn of of the low pass filter and gain instantly sounds broken at low volume. I think mine were already somewhat blown because they sound terrible and a bit muffled.

    So the question is about the JL min subs, and low pass filtering... will I be missing too much mid bass if I go with a real sub class for the middle and low pass filter it for nice low bass?.

    Has anyone tried real "mini subs" ?

    N
     
  2. moparracing

    moparracing Enthusiast

    Posts:
    354
    Joined:
    Jan 16, 2009
    Location:
    Battle Ground, Wa
  3. s66353h

    s66353h Viper Owner

    Posts:
    34
    Joined:
    Jan 21, 2013
    Location:
    Clifton Park, NY
    I use them. Take a look at the pics on my profile. They look and sound great.
     
  4. fed007

    fed007 Enthusiast

    Posts:
    40
    Joined:
    Apr 8, 2009
    OK Done deal, just ordered two JL Audio 6.5 in subs!

    So I got the stereo completed for the doors last night about 1:30 am, went to fire up the car , and it wouldn't start!!!

    I had moved the fuel pump relay wiring to fit my 4 gauge amp wires through the trunk grommet and forgot to reconnect them thinking they were originally the stock amp power lines.... so it wouldn't matter ... :) anyhow all solved now! and the Mid range in nicely filled in by the engine!! great combo so far, the subs should be the cherry on top. A very low frequency cherry that is. :)

    N
     

Share This Page