Need a John Reed Wiring Harness for AEM Paxton! Anyone have one???

ZDigital1

Viper Owner
Joined
Jun 25, 2006
Posts
255
Reaction score
0
Location
Peoria, Illinois
I posted my request in the "Wanted Classified Section". I have a AEM set up with a Paxton and I am in need of the John Reed Wiring Harness for my Gen 3.
John Reed has not been cooperative at all in repairing my harness which had a defective connector. I've been waiting for over 2 months to get a response from him!! Not a happy camper!

If you have one that you are willing to sell, please call me at 309-696-7575.
Thanks in advance,
Scott Tallyn
 

Viper Specialty

Viper Owner
Joined
Feb 14, 2002
Posts
5,601
Reaction score
1
Location
Cape Coral, FL
Which connector is damaged, and how? We build MIL-Spec harnesses on a daily basis here, and can certainly repair it for you as long as the parts are currently available.
 

ZDigital1

Viper Owner
Joined
Jun 25, 2006
Posts
255
Reaction score
0
Location
Peoria, Illinois
Which connector is damaged, and how? We build MIL-Spec harnesses on a daily basis here, and can certainly repair it for you as long as the parts are currently available.

Greetings Dan,
The connector that has the issue is the one that connects to the AEM. I'm not certain as to the actual name of it but if you are looking at the AEM with the power connector positioned at the top, the connector that is broken plugs in to the far right connector on the AEM. (there are 3 of these connectors all in a row on the AEM). The AEM connectors are all in perfect shape.

The connector had a broken tab that locks all of the wire leads in place. The issue I'm having is trying to get my harness back from John Reed. I'm pretty ****** off about this!
I appreciate the response.
Scott
 
Last edited:

Viper Specialty

Viper Owner
Joined
Feb 14, 2002
Posts
5,601
Reaction score
1
Location
Cape Coral, FL
Greetings Dan,
The connector that has the issue is the one that connects to the AEM. I'm not certain as to the actual name of it but if you are looking at the AEM with the power connector positioned at the top, the connector that is broken plugs in to the far right connector on the AEM. (there are 3 of these connectors all in a row on the AEM). The AEM connectors are all in perfect shape.

The connector had a broken tab that locks all of the wire leads in place. The issue I'm having is trying to get my harness back from John Reed. I'm pretty ****** off about this!
I appreciate the response.
Scott

Understood. Sorry about your troubles, John has always been a stand-up guy, there has to be something going on out of his control. I hope you get it sorted quickly!
 

Members online

Forum statistics

Threads
151,770
Posts
1,672,411
Members
15,859
Latest member
ViperRaptor
Top