Gen 1 Headlight Switch Issue

GA- Viper

Enthusiast
Joined
May 6, 2019
Posts
19
Reaction score
3
Location
Atlanta
My 95 with 8,500 miles is rarely driven that I have need for the headlights and the headlight switch has not been used in close to a year. Last night I had no headlights, or tail lights but the brake lights worked. I moved the headlight switch in and out numerous times and finally got them to flicker and then work. This has happened before so I thought it best to get a new switch. I purchased one at NAPA and it appeared the same dimensionally and connections. All was going fine with the install until I tried getting the switch ****/shaft to engage the light switch. It would push in but not latch. Tried all combinations including pushing the top release button with no success. The strange part is that it will latch in the switch when not mounted in the dash. Thinking this might be a manufacturing defect or slight dimensional difference I purchased another light switch at Advance Auto. And had the same problem getting the ****/shaft to latch. Has anyone experienced this problem? And know of a part that will mount and latch correctly?

The OEM switch is re installed shows no corrosion and the wiring connection shows no signs of over heating as others have experienced. And for now, I again have all lights functioning.
Thanks.
 
Top