1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

2005 shifter vibrates...is this normal?

Discussion in 'SRT10 and SRT10 Coupe Discussions' started by Buzz6591, Feb 5, 2019.

  1. Buzz6591

    Buzz6591 Enthusiast

    Posts:
    4
    Joined:
    Dec 12, 2018
    Location:
    Atlanta
    I am a first time Viper owner, 2005. When the car idles, the shifter vibrates. When driving, and I accelerate, the shifter torques....especially with a rapid and sudden acceleration. With a very rapid acceleration that causes the tires to spin, the shifter torques violently. Is this normal, or does it indicate a broken motor mount, or some other issue? Not sure if this matters, but the car does have a short shifter. Thank you for helping!
     
  2. MoparMap

    MoparMap VCA National President

    Posts:
    1,558
    Joined:
    Jan 7, 2013
    Location:
    Kansas
    Sounds like a motor mount to me. I'd pop the hood and flick the throttle and watch and see what it does. The shifter should stay pretty stable. Another common sign of a bad motor mount is if you look on the insulation pad on the bottom of the hood. Mine has a small hole where the throttle cable attaches to the throttle body because the engine kept torquing up and rubbing on the insulation. I've since replaced the mounts. Not a terrible job, but it can take a bit.
     
    Buzz6591 likes this.
  3. Buzz6591

    Buzz6591 Enthusiast

    Posts:
    4
    Joined:
    Dec 12, 2018
    Location:
    Atlanta
    Thank you MoparMap!
     
  4. fhrzr1

    fhrzr1 Enthusiast

    Posts:
    17
    Joined:
    Nov 26, 2016
    Location:
    Cocoa, Florida
    That is not normal on the 2005.
     

Share This Page