Help Needed: Driver Side Power Window and Buttons Issue

hydronos

Enthusiast
Joined
May 26, 2020
Posts
3
Reaction score
1
Location
Chicago
Hi, I'm facing an issue with my 2016 viper. The driver side power window and buttons are not working. Checked fuses and relays - all good. Additionally, the window doesn't roll down slightly when opening/closing the door. Could it be the switch, body control module, or damaged wiring? It seems like the switch isn't receiving any power and passenger side is working just fine. I checked fuses 18 and relay 65 are those the right ones?
 
Last edited:

Reguy

Enthusiast
Joined
May 19, 2019
Posts
8
Reaction score
4
Location
New York
Sounds like it could be the window regulator or the body control module.
 
OP
OP
H

hydronos

Enthusiast
Joined
May 26, 2020
Posts
3
Reaction score
1
Location
Chicago
Sounds like it could be the window regulator or the body control module.
I was actually able to get the window to work by swapping in a new door control module.

Now if I could just get this window re learn to work. The windows going down fine, it's just when it goes up in auto it goes up 90% of the way and then rolls back down. If I hold it manually it'll go up and come down a 1/4 of a inch and then when I click it and hold it back up it'll close completely.
 

kbench55

Viper Owner
Joined
Aug 4, 2015
Posts
6
Reaction score
0
I was actually able to get the window to work by swapping in a new door control module.

Now if I could just get this window re learn to work. The windows going down fine, it's just when it goes up in auto it goes up 90% of the way and then rolls back down. If I hold it manually it'll go up and come down a 1/4 of a inch and then when I click it and hold it back up it'll close completely.
Have you tried the relearn process. Press and hold the down button until it is completely down and continue holding it for 5 seconds. Then press and hold the up button until it is completely up and continue to hold it for 5 seconds. I have had to do this a few times in my 2014 and it always works.
 

Ritroman

Enthusiast
Joined
Jun 15, 2023
Posts
11
Reaction score
1
Location
pensylvania
The window regulator may be cracked. My Gen 5 had a broken regulator that burned out the window control module. The motor may be working too hard to move the window and drawing too much current. You may need to replace the window regulator. Did you inspect the window regulator yet?
 

Latest posts

Forum statistics

Threads
153,308
Posts
1,682,829
Members
17,824
Latest member
J_boguejr
Top