93 Viper RT 10 Radio issues

LDIXON3191

Enthusiast
Joined
Feb 19, 2022
Posts
10
Reaction score
0
Location
Edgewood
We are having issues trying to figure out why the radio works sometimes, but than looses connection. We've taken it to multiple Stereo/Radio and electrical business. Not one person can figure this out.

It is a rear antenna.

Any ideas what we could be missing?
 
OP
OP
LDIXON3191

LDIXON3191

Enthusiast
Joined
Feb 19, 2022
Posts
10
Reaction score
0
Location
Edgewood
Will attempting to install "door poppers" complicate the radio issue/s, as I'm being told the poppers are tethered through radio wires that run from the dash, through the door panels to the amplifiers in the trunk.
 

Dan Cragin

Legacy/Supporting Vendor
Supporting Vendor
Joined
Feb 16, 2007
Posts
1,244
Reaction score
6
Location
LA, CA
Often times its the antenna signal amplifier. Mounted under the dash on the passenger side.
 
OP
OP
LDIXON3191

LDIXON3191

Enthusiast
Joined
Feb 19, 2022
Posts
10
Reaction score
0
Location
Edgewood
So this is a rear antenna Viper. There is a signal panel under the dash on the passengers side?

I just had a Viper Tech tell me to remove the drivers side door and dash under the driver's side and ground the green hanging wire.
 

MoparMap

VCA National President
VCA Officer
Joined
Jan 7, 2013
Posts
1,930
Reaction score
110
Location
Kansas
Will attempting to install "door poppers" complicate the radio issue/s, as I'm being told the poppers are tethered through radio wires that run from the dash, through the door panels to the amplifiers in the trunk.

Are you just doing door poppers or are you running a trunk one too? If you're just running stuff for the doors I don't see why you'd be running wires back to amplifiers. I put a driver's side popper in my mom's 94 and it was just a single wire from the popper to the alarm module on the left side of the transmission tunnel up by the throttle pedal. Either way they would only ever be active for the brief moment you hit the button to open them, so can't imagine they should cause any issues.
 
OP
OP
LDIXON3191

LDIXON3191

Enthusiast
Joined
Feb 19, 2022
Posts
10
Reaction score
0
Location
Edgewood
We can't get the radio to work. It's a back ******* antenna. The two amplifiers are in the truck. The FOB doesn't work. We can't find anyone to fix these issues.
 

Walter Clark

Enthusiast
Joined
May 22, 2021
Posts
7
Reaction score
2
Location
North Carolina
Sounds like two issues. If you key fob doesnt work, and assuming it is the correct one for the Viper, You need to go thru the reprogramming sequence in the service manual. That is where the green wire the tech mentioned comes in.

When you say the radio doesnt work, please be more specific. Is it every source that cuts off randomly? Just AM/FM?

With mine, the issue was the balance and fader sliders were badly contaminated and any vibration of the vehicle would cause the wipers on these pots to lose contact and either cut off or badly distort the sound.
 

Latest posts

Members online

Forum statistics

Threads
152,025
Posts
1,673,866
Members
16,307
Latest member
Thesweepman
Top